1.题目
Description
In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.
Input
The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.
Figure 1: The starting positions of the robots in the sample warehouse
Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of
L: turn left 90 degrees,
R: turn right 90 degrees, or
F: move forward one meter,
and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.
Output
Output one line for each test case:
Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
OK, if no crashing occurs.
Only the first crash is to be reported.
Sample Input
4 5 4 2 2 1 1 E 5 4 W 1 F 7 2 F 7 5 4 2 4 1 1 E 5 4 W 1 F 3 2 F 1 1 L 1 1 F 3 5 4 2 2 1 1 E 5 4 W 1 L 96 1 F 2 5 4 2 3 1 1 E 5 4 W 1 F 4 1 L 1 1 F 20
Sample Output
Robot 1 crashes into the wall Robot 1 crashes into robot 2 OK Robot 1 crashes into robot 2
2.题意
就是说给定机器人,然后给定他们的位置和前进方向,然后再给出他们接下来会发生的动作,判定是否会撞墙,或者是否或撞到其他机器人
3.思路
没啥思路,现在才发现模拟题,就是一步一步的走,其实都不是很复杂啦
4.代码(Accept)
#include<iostream>
using namespace std;
int row = 0;
int col = 0;
int robotNum = 0;
int instructionNum = 0;
struct robot
{
int x;
int y;
char direction;
};
robot robotList[110];
char s[] = {'E','N','W','S'};
int isCheck(int robotNo,int x,int y) {
for (int i = 1;i <= robotNum;i++) {
if(i == robotNo) continue;
if(robotList[i].x == x && robotList[i].y == y) return i;
}
return 0;
}
bool isCrash(int robotNo,char action,int repeatNum){
if(action == 'F'){
char direction = robotList[robotNo].direction;
int x = robotList[robotNo].x;
int y = robotList[robotNo].y;
if(direction == 'E'){
int xx = x + repeatNum;
for (int i = x + 1; i <= xx; i++){
if(i > row){
cout<<"Robot " << robotNo << " crashes into the wall" << endl;
return true;
}
int rR = isCheck(robotNo,i,y);
if(rR != 0){
cout << "Robot " << robotNo << " crashes into robot " << rR << endl;
return true;
}
}
robotList[robotNo].x = xx;
}else if(direction == 'W'){
int xx = x - repeatNum;
for (int i = x - 1; i >= xx; i--){
if(i <= 0) {
cout << "Robot " << robotNo << " crashes into the wall" << endl;
return true;
}
int rR = isCheck(robotNo,i,y);
if(rR != 0){
cout << "Robot " << robotNo << " crashes into robot " << rR << endl;
return true;
}
}
robotList[robotNo].x = xx;
}else if(direction == 'N'){
int yy = y + repeatNum;
for (int i = y + 1; i <= yy; i++){
if(i > col) {
cout << "Robot " << robotNo << " crashes into the wall" << endl;
return true;
}
int rR = isCheck(robotNo,x,i);
if(rR != 0){
cout << "Robot " << robotNo << " crashes into robot " << rR << endl;
return true;
}
}
robotList[robotNo].y = yy;
}else{
int yy = y - repeatNum;
for (int i = y - 1; i >= yy; i--){
if(i <= 0) {
cout << "Robot " << robotNo << " crashes into the wall" << endl;
return true;
}
int rR = isCheck(robotNo,x,i);
if(rR != 0){
cout << "Robot " << robotNo << " crashes into robot " << rR << endl;
return true;
}
}
robotList[robotNo].y = yy;
}
}
else{
int pp = repeatNum % 4;
int i = 0;
for (;i < 4;i++) {
if(robotList[robotNo].direction == s[i]) break;
}
if(action == 'L')
robotList[robotNo].direction = s[(i + pp) % 4];
else
robotList[robotNo].direction = s[(i+4-pp) % 4];
return false;
}
return false;
}
int main(){
int testcase = 0;
cin>>testcase;
while(testcase --) {
cin>>row>>col;
cin>>robotNum>>instructionNum;
for (int i = 1;i <= robotNum;i++) cin>>robotList[i].x>>robotList[i].y>>robotList[i].direction;
int robotNo = 0;
char action ;
int repeatNum = 0;
bool op = false;
for (int i = 0;i < instructionNum;i++) {
cin>>robotNo>>action>>repeatNum;
if(op) continue;
if(isCrash(robotNo,action,repeatNum)) op = true;
}
if(!op) cout << "OK" << endl;
}
return 0;
}